Autor Thema: Fehler in der URL Ausgabe als Bilder  (Gelesen 13119 mal)

Nem

  • Forenfetischist
  • ****
  • Beiträge: 888
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #25 am: 19. Juli 2009, 12:36:24 »
Werde heute mal nachschauen woran das liegen könnte.

Gruß Nem

Übersicht über die Java-Skripte: http://mirandanem.mi.funpic.de/



Xannasavin

  • Tastaturschoner
  • **
  • Beiträge: 25
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #26 am: 19. Juli 2009, 20:28:50 »
Wie weit seid ihr eigentlich mit der DocType unabhängigen Lösung?
Ich hab zwar n anderes Template gefunden, aber suprise-surprise es hat wieder keinen Doc Type -_-

Grüße

Nem

  • Forenfetischist
  • ****
  • Beiträge: 888
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #27 am: 20. Juli 2009, 18:48:30 »
Hi

Es wird nie eine DocType unabhängige Lösung geben. Was hier integriert wird ist
eine "automatische" Erkennung welcher DT benutzt wird.

Gruß Nem

Übersicht über die Java-Skripte: http://mirandanem.mi.funpic.de/



Xannasavin

  • Tastaturschoner
  • **
  • Beiträge: 25
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #28 am: 20. Juli 2009, 19:45:24 »
Dein Problem ist das bei dir kein DOC-TYPE im Skin angegeben werden kann und im Originalen waren alle Skripte auf einen DOC-TYPE angewiesen.
Und wir sind gerade erst am Umbauen. Also noch ein wenig abwarten.

Das hat sich halt danach angehört T_T
Ist doch zum Mäusemelken... Sämtliche Styles die ich bis jetzt gefunden haben und die gut aussahen, haben keinen DT drinstehn -.-

Dark-Water

  • Gast
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #29 am: 20. Juli 2009, 23:28:46 »
ähm so gut wie kein Template hat einen DOC-TYPE Eintrag.

Du kannst ja einfach mal einen eintragen und probieren ob das Template vollständig funktioniert.
(einfach in den Anfang der IVT Datei schreiben)

Zitat von: www.w3.org
HTML 4.01 - Strict, Transitional, Frameset:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN"
   "http://www.w3.org/TR/html4/strict.dtd">
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
   "http://www.w3.org/TR/html4/frameset.dtd">
   
XHTML 1.0 - Strict, Transitional, Frameset:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
   "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
   "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN"
   "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
   
XHTML 1.1 - DTD:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
   "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
   
XHTML Basic 1.0 - DTD:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML Basic 1.0//EN"
    "http://www.w3.org/TR/xhtml-basic/xhtml-basic10.dtd">
   
XHTML Basic 1.1 - DTD:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML Basic 1.1//EN"
    "http://www.w3.org/TR/xhtml-basic/xhtml-basic11.dtd">
   
HTML 2.0 - DTD:
<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
HTML 3.2 - DTD:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
MathML 1.01 - DTD:
<!DOCTYPE math SYSTEM
   "http://www.w3.org/Math/DTD/mathml1/mathml.dtd">
   
MathML 2.0 - DTD:
<!DOCTYPE math PUBLIC "-//W3C//DTD MathML 2.0//EN"   
   "http://www.w3.org/TR/MathML2/dtd/mathml2.dtd">
   
XHTML + MathML + SVG - DTD:
<!DOCTYPE html PUBLIC
    "-//W3C//DTD XHTML 1.1 plus MathML 2.0 plus SVG 1.1//EN"
    "http://www.w3.org/2002/04/xhtml-math-svg/xhtml-math-svg.dtd">
   
SVG 1.0 - DTD:
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.0//EN"
   "http://www.w3.org/TR/2001/REC-SVG-20010904/DTD/svg10.dtd">
   
SVG 1.1 Full - DTD:
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
   "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
   
SVG 1.1 Basic - DTD:
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1 Basic//EN"
   "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11-basic.dtd">
   
SVG 1.1 Tiny - DTD:
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1 Tiny//EN"
   "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11-tiny.dtd">
   
XHTML + MathML + SVG Profile (XHTML as the host language) - DTD:
<!DOCTYPE html PUBLIC
    "-//W3C//DTD XHTML 1.1 plus MathML 2.0 plus SVG 1.1//EN"
    "http://www.w3.org/2002/04/xhtml-math-svg/xhtml-math-svg.dtd">
   
XHTML + MathML + SVG Profile (Using SVG as the host) - DTD:
<!DOCTYPE svg:svg PUBLIC
    "-//W3C//DTD XHTML 1.1 plus MathML 2.0 plus SVG 1.1//EN"
    "http://www.w3.org/2002/04/xhtml-math-svg/xhtml-math-svg.dtd">

Der folgende dürfte in vielen fällen funktionieren:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN"
   "http://www.w3.org/TR/html4/strict.dtd">

kaye_styles

  • Tastaturquäler
  • **
  • Beiträge: 394
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #30 am: 21. Juli 2009, 00:23:01 »
Also wenn würde ich doch eher zu dem hier raten:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
Der von dir genannte basiert ja auf dem strengeren Regelwerk. Deshalb steigt die Wahrscheinlichkeit, dass er eben doch nicht funktioniert. Aber da hilft nichts anderes als ausprobieren. :)


Ich hätte auch noch ein Anliegen. Da einige von euch ja doch schon viel mit verschiedenen Templates rumexperimentiert haben. Welche haben sich denn als besonders schwierig im Zusammenspiel mit den Skripten erwiesen oder gibt es gar welche, die bisher gar nicht laufen? Ich bräuchte ein paar Exemplare zum Testen.
« Letzte Änderung: 21. Juli 2009, 00:31:50 von kaye_styles »

Nem

  • Forenfetischist
  • ****
  • Beiträge: 888
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #31 am: 21. Juli 2009, 00:38:02 »
Hi

Je nachdem wie die IVT programmiert wurde muss ein anderer DOCTYPE benutzt werden.

Der Tag
 wird so bei XHTML benutzt, während
 bei HTML verwendet wird.
Es ist als darauf zu achten, dass nicht verschiedene (X)HTML Stiele in einer Datei
zusammen kommen.

Auf meiner Seite der Skin benutzt:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
Der ist halt auch recht einfach gehalten.

Übersicht über die Java-Skripte: http://mirandanem.mi.funpic.de/



Dark-Water

  • Gast
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #32 am: 21. Juli 2009, 20:13:33 »
am schwierigsten stellen sich Templates mit JavaScript Dateien raus, weil die öfters schon eine eigene Text Umwandlung/Änderung besitzen.
Und einige wenige mit separater CSS Datei.

Xannasavin

  • Tastaturschoner
  • **
  • Beiträge: 25
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #33 am: 21. Juli 2009, 21:01:55 »
hey ich hab den splash screen nochmal komplett neu aufgezogen, einziger fehler bis jetzt: menue.js, datei wird nicht gefunden (ist aber vorhanden)#

doctype hab ich den hier genommen:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

die scripts.js die beim splash dabei ist hab ich in den scripte ordner von nem gepackt...

zeile38
zeichen 2
fehler: die datei wurde nicht gefunden
code 0
file: menue.js

/e fehler 2:

zeile150
zeichen 13
fehler: objekt erforderlich
code 0
file: allglobalfunctions.js

/e fehler 3 (youtube)

zeile428
zeichen 9
fehler: objekt erforderlich
code 0
file: allglobalfunctions.js
« Letzte Änderung: 21. Juli 2009, 21:09:38 von Xannasavin »

Nem

  • Forenfetischist
  • ****
  • Beiträge: 888
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #34 am: 21. Juli 2009, 21:29:43 »
@Putty

Hallo,

ich muss das Thema mit dem doppelten http:// nochmal aufgreifen. Nutzer berichten folgendes:

Zitat
egal wie sobald ein link mit www. angefangen oder schon mit http:// fügt er ein zusätzliches hinzu kommt allerdings beim gegnüber nciht an
Zitat
ich kopier den link mit strg+c und füge ihn mit strg+v ein…im fenster unten steht er dann ganz normal drinnen, aber sobald ich dann auf senden drücke ist er “falsch” und wird mit 2 mal http vor dem link angezeigt^^

Laut meinem template wird in den o.g. Fällen ich auch die aktuelle convert.js 0.3.0.11 verwendet.
Sollte das damit nicht behoben sein?
Ich selbst kann es aber leider auch nicht reproduzieren. An was kann es denn noch liegen?

Bei einem Link, der nicht als "normaler" Link erkannt wird kann es vorkommen, dass ein weiteres http davor geschrieben wird. Bisher kann ich leider noch nicht sagen, wann genau das immer auftritt.
z.B. : http:\\www.

gruß Nem

EDIT:
Setz mal in der basicfile.js die variable test=10. Dann erkennst Du, dass bei der "original" Message schon ein Link mit http erst ab den www als Link behandelt wird. Somit wird das Problem nicht von den Skripten hervorgerufen sondern von tabsrmm.

EDIT2:
Habe nun ein wenig rumprobiert. Denke mal die Links haben nicht http:// sondern http:\\ enthalten. Falls ich mich irre, sag mir bescheid und schick mir mal einen Link zu, bei dem dann das Problem auftritt.
« Letzte Änderung: 21. Juli 2009, 21:49:42 von Nem »

Übersicht über die Java-Skripte: http://mirandanem.mi.funpic.de/



Dark-Water

  • Gast
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #35 am: 21. Juli 2009, 21:43:16 »
@Xannasavin

Warum haste denn die script.js in den IEView-Skript Ordner gepackt ?
Diese Datei gehört doch zum Template, also dahin wo die *.IVT Datei ist.

Xannasavin

  • Tastaturschoner
  • **
  • Beiträge: 25
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #36 am: 21. Juli 2009, 22:18:10 »
@Xannasavin

Warum haste denn die script.js in den IEView-Skript Ordner gepackt ?
Diese Datei gehört doch zum Template, also dahin wo die *.IVT Datei ist.

servus!

wollte es "sauber" lösen, und da alle script dateien im skripte ordner geladen werden und ich ja nur den einen skin verwende, kann dessen skript ja auch aus dem ordner geladen werden, oder nicht? o0
kann es auch wieder zurückpacken, wenn das was an den fehlern ändern sollte ^^

grüße

puttee

  • Tastaturquäler
  • **
  • Beiträge: 355
  • Geschlecht: Männlich
  • www.puttee.de | Miranda Fusion
    • Profil anzeigen
    • www.puttee.de | www.miranda-fusion.de
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #37 am: 23. Juli 2009, 10:01:57 »
@NEM

Ich geb mal das weiter was der User bei mir berichtet:
Zitat
Also, mir fällt auf des es bei manchen links  geht weiß aber nicht bei welchern und ob von mir oder vom gegenüber geschickt, sicher ist wenn gegenüber und ich schicken ist es immer bei youtube und schuelervz also immer ganz normal http:// und nicht http:\\
es sind allgemein alle video links von youtube bei denen es mir auffält
und es ist immer copy & paste^^

Wie gesagt ich kann es selber auch nicht reproduzieren. Kommt es denn bei dir manchmal vor?
Motto: Optimisten haben gar keine Ahnung von den freudigen Überraschungen, die Pessimisten erleben.

SaVita

  • Gast
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #38 am: 23. Juli 2009, 14:34:06 »
hallo, bei mir funktioniert alles super, außer bei erstmaligen starten einen chatfensters, da kommt die fehlermeldung "die datei wurde nicht gefunden". der !tools ordner scheint mir aber komplett zu sein.

habe die menu.js gelöscht, braucht nur tzers. nun ist alles bestens.

ein schönheitsfehler habe ich noch , die smilies werden verzerrt dargestellt. wo könnte ich das ändern?

alles klar

Zitat
// parser: Smileygröße ändern in der CSSbei ".img"
  //message = message.replace(/<img class="img" src="file:\/\//g,'<img class="textimages" src="file://');
 

 ;)
« Letzte Änderung: 23. Juli 2009, 15:17:55 von SaVita »

Nem

  • Forenfetischist
  • ****
  • Beiträge: 888
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #39 am: 24. Juli 2009, 22:10:03 »
@puttee
Ich hatte das nur einmal, als mich jemand darauf aufmerksam machte, dass Links von dem mindestens ein Buchstaben bei http groß geschrieben wurde mit doppelten http:\\ erscheinen. Seitdem halt nicht mehr, da ich dieses Problem (anscheinend wohl nicht ganz) behoben habe.
Solange ich keine Links bekomme kann ich da auch nichts machen. Habe nun einige ausprobiert und alle ohne dem doppelten http.

@all
Was passiert bei euch mit Links die mit www anfangen aber nicht alle Buchstaben davon klein sind?
Bei mir werden die dann nicht als Links erkannt. Habe mir die convert.js mal so umgeschrieben,
dass die nun auch umgewandelt werden.

Gruß Nem
« Letzte Änderung: 24. Juli 2009, 22:20:50 von Nem »

Übersicht über die Java-Skripte: http://mirandanem.mi.funpic.de/



Nem

  • Forenfetischist
  • ****
  • Beiträge: 888
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #40 am: 27. Juli 2009, 22:30:11 »
Hi

Habe nun ein eine neue convert.js auf meiner Seite, die verarbeitet nun auch Links mit
wWW, wwW, usw.
Bei mir läuft sie ohne Probleme, falls irgendwo Fehler auftreten bitte bescheid geben und
mir am besten den fehlerhaften Link zukommen lassen.

Gruß Nem

Übersicht über die Java-Skripte: http://mirandanem.mi.funpic.de/



Xannasavin

  • Tastaturschoner
  • **
  • Beiträge: 25
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #41 am: 28. Juli 2009, 17:52:16 »
hab jetzt menue, clock und tvstream entfernt und es funktioniert soweit. nur wenn ich über einen link fahre, zeigt er mir nen fehler in der allglobalfunctions.js an...

achja, in der parser.js

  // parser: Bilder von http://www.upload.de anzeigen
  message = message.replace(/http\:\/\/www.abload.de\/image.php\?img\=/g, 'http://www.abload.de/img/');

Upload oder Abload? o0

Nem

  • Forenfetischist
  • ****
  • Beiträge: 888
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #42 am: 28. Juli 2009, 22:40:36 »
Gute Frage.

Habe es nie getestet mit:
Zitat
// parser: Bilder von http://www.upload.de anzeigen
  message = message.replace(/http\:\/\/www.abload.de\/image.php\?img\=/g, 'http://www.abload.de/img/');
Habe das mal für jemanden reingepackt, was für ihn wohl ging, da keine Beschwerden kamen.

Benutzt jemand das denn überhaupt noch?
Ansonsten könnte man es wieder raus nehmen.

In der Basic Datei kannst Du angeben welche Erweiterungen benutzt werden sollen und welche nicht. Probier mal
da ein wenig rum, damit du den Fehler eingrenzen kannst.

Gruß Nem.



Übersicht über die Java-Skripte: http://mirandanem.mi.funpic.de/



Xannasavin

  • Tastaturschoner
  • **
  • Beiträge: 25
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #43 am: 29. Juli 2009, 19:04:08 »
Ist mir nur aufgefallen ^^

Also in der allglobal war es glaub ich die zeile 150, ein teil der function mausdrauf(ids) {
            scrollPos     = document.getElementById("Body").scrollTop;


das kommt wenn ich z.b. ein bild aufgeklappt hab und dann auf den bildlink komme, bzw auch generell wenn ich auf einen video oder bildlink komme... ist natürlich etwas unpraktisch, da er ja klickbar sein sollte ^^

der tag class body ist natürlich bei <body> drin... 2x (warum auch immer 2x? o0 steht so in deiner anleitung ^^)

Nem

  • Forenfetischist
  • ****
  • Beiträge: 888
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #44 am: 29. Juli 2009, 20:39:21 »
Hi

Bei mir steht nichts doppelt im Body Tag.
Da steht drin: <body class="body" id="body">

Ich habe kein Problem mit dem Mouseover (siehe Bild).Könnte bei Dir ggf an dem installierten
IE-Browser liegen.

Gruß Nem

Übersicht über die Java-Skripte: http://mirandanem.mi.funpic.de/



Xannasavin

  • Tastaturschoner
  • **
  • Beiträge: 25
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #45 am: 29. Juli 2009, 21:17:18 »
aha, vllt löst das ja das problem - in deiner anleitung steht
Zitat
- den <body>-Tag mit class="body" und class="body" erweitern
z.B. sieht es dann so aus: <body class="body" class="body">

hatte mich schon gewundert warum 2x die gleiche class gegeben wird (bzw warum überhaupt 2x ne class ^^) ich probiers mal mit id statt dem 2. class ;)

Nem

  • Forenfetischist
  • ****
  • Beiträge: 888
  • Geschlecht: Männlich
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #46 am: 01. August 2009, 02:54:40 »
oh jau. Habe es nun korrigiert. Danke.

Nun steht es in der Installationsanweisung mit "<body id="body" class="body">" richtig.

gruß Nem

Übersicht über die Java-Skripte: http://mirandanem.mi.funpic.de/



Xannasavin

  • Tastaturschoner
  • **
  • Beiträge: 25
    • Profil anzeigen
Re: Fehler in der URL Ausgabe als Bilder
« Antwort #47 am: 03. August 2009, 19:00:29 »
also ein paar skripte hab ich rausgenommen und inzwischen läuft das ganze auch auf meinem tollen skin und scheint keine fehler mehr zu machen - nur youtube hab ich noch nicht ausprobiert ;)

aber sieht soweit gut aus :D *party*